0 users browsing Mario Making Mods Talk. | 1 guest

  • Normal user
Since: 01-20-19
I've gone into multiple threads of different mods in the depot, but anything that is "hidden" behind a button like "Download" or "Screenshots" just does... nothing.

I click on the button a million times but nothing happens. It doesn't expand, it doesn't show anything, just nothing. I've even tried looking at this site in three different browsers and they just don't work.

I've tried multiple threads about mods on this site like the buttons on the "Retro Mario Bros" or "Deltarune Theme" pack and those buttons do nothing, I can't see any screenshots, I can't download, I can't do anything unless it's in a normal link. Is this going to be fixed so the site can be used? Because I don't get what's going on.
Posted on 01-20-19, 12:34 pm (rev. 1 by NightStar on 01-20-19, 12:35 pm)
  • Owner
Since: 05-17-17
From: Mushroom Kingdom
Seems like the spoilers button is broken. Though, it's weird, because I never touched the spoilers button. I'll open up my console log later today (it's 6:00 AM right now)

Also, the only other theme that have broken "download 3DS/Wii U themes" that I'm aware of is the themes by Louiskovoski, which still point to the now dead DSHack. I'll fix those once my Internet comes online, though do you mind telling me if you find some that don't work.

Speaking of spoilers, yeah, they're used for the wrong reasons. They shouldn't be used to hide links and stuff like that. While the spoilers should be fixed, I'm also going to edit some of the depot entries that use them because you shouldn't be using them like that.

Also, would you mind linking me to threads that you found spoilers in them for download links?
Old 3DS XL info:
I used to have a 3DSafe A9LH V11.3.0-36U with Luma in my CTRNAND. Since ReiNAND Reibooted and Re-Reileased, I "switch"ed back.
Right now, I have boot9strap with Luma 8.0 as my CFW. Though, I'd like to see other CFW's for B9S.
Posted on 01-20-19, 02:04 pm
  • Normal user
Since: 07-12-18
HOLY FRICK!
MAH THOUHZ ECSACULLY!
Posted on 01-20-19, 06:01 pm
  • Owner
Since: 05-17-17
From: Mushroom Kingdom
I have fixed the bug.

To explain more in depth, it was relating to a change I have previously made to the engine known as TimeAgo.
Lately, I've been trying to make things lightweight for users with old devices (well, old devices that support HTTPS. I'm not going to be supporting Dial-Up device :P), and there was one thing I was trying really hard to remove: The usage of jquery. It makes everything really laggy on older devices and it's one of those things that need to be removed. I've started the process by making TimeAgo use the no-jquery fork, which required me to remove the following bit of code:

$(document).ready(
    function () { 
        $(".spoilerbutton").click(toggleSpoiler);
        jQuery.timeago.settings.strings = {
            prefixAgo: '',
            prefixFromNow: '',
            suffixAgo: 'ago',
            suffixFromNow: 'from now',
            seconds: '%d seconds',
            minute: "%d minute",
            minutes: "%d minutes",
            hour: "%d hour",
            hours: "%d hours",
            day: "%d day",
            days: "%d days",
            month: "%d month",
            months: "%d months",
            year: "%d year",
            years: "%d years"
        };
        //jQuery.timeago.settings.cutoff = 1000;
        $('time.timeago').timeago();
    }
);
If you can read the code properly, you would notice the use of $(".spoilerbutton").click(toggleSpoiler);, which allows spoilers to be toggled. Since I didn't read the code correctly (was studying for school finals), I thought the entire function was jquery timeago and just removed it. However, when looking through the ABXD repository, I've noticed my mistake and have fixed it.

Thankfully, the other changes on that day were all carefully done, so I guess it was one rotten egg.
However, since it's a change to a CSS or a JS file, you'll need to reload your cache. On android, go to settings, apps, (web browser), remove cache. On Windows, do CTRL + F5. I'm not sure the command to do so on a Mac, so MoonlightCapital will let you know.

I am sorry for this whole mess, and I hope nothing like this happens in the future.
Old 3DS XL info:
I used to have a 3DSafe A9LH V11.3.0-36U with Luma in my CTRNAND. Since ReiNAND Reibooted and Re-Reileased, I "switch"ed back.
Right now, I have boot9strap with Luma 8.0 as my CFW. Though, I'd like to see other CFW's for B9S.
Posted on 01-20-19, 07:03 pm
  • Normal user
Since: 05-19-17
From: Italy
CTRL + SHIFT + R to refresh cache on Mac (at least if you use Firefox).


Certificate for nickname MoonlightCapital, is registered to: MoonlightCapital
Nickname database
Posted on 01-21-19, 01:27 pm
SamplasionUser is Offline
Someone
  • Normal user
Since: 11-15-17
From: i dont know
CTRL + SHIFT + R to refresh cache on Mac (at least if you use Firefox).
On Chrome it's the same keys, as far as I can tell. Or you can clear it by going into Settings > Advanced > Privacy and Security > Clear navigation data > Advanced and checking "Images and files stored in cache"

My Website

Posted on 01-22-19, 02:39 pm